Please login or register.

Login with username, password and session length
Advanced search  


Pages: [1] 2 3 ... 10
 on: March 21, 2018, 03:58:41 PM 
Started by Carbon_ZX6R - Last post by Carbon_ZX6R
These things still about ? Can't find anything online?

 on: March 20, 2018, 08:17:46 AM 
Started by CBr6y - Last post by Alzo
No.... :rofl:

 on: March 19, 2018, 06:27:16 PM 
Started by CBr6y - Last post by CBr6y
Visual  checks already carried out ar the time it occurred,  couldn't see anything out the ordinary whatsoever. Garage confirmed in one of the phone conversations that slave cylinder had been checked and was fine/dry and no sign of any issues,

The bike will get checked over by a garage we know and trust for piece of mind, was just curious if anyone had any other ideas or had any experience of something similer, just on the off chance.

 on: March 18, 2018, 02:59:40 PM 
Started by CBr6y - Last post by Alzo
It's a basic hydraulic set any failure is only attributable to air (seal  failure)....degraded lines...connections...or moisture....but moisture doesn't usually lead to full failure....just spongy.. No idea why the garage is being so coy....but I honestly don't think you have much to worry about...if you have no confidence in their fix then for peace of mind get it checked over elsewhere
A visual check and new fluid by yourselves if you feel so inclined.

 on: March 18, 2018, 01:51:36 PM 
Started by CBr6y - Last post by CBr6y
It's all a bit odd. Garage really didn't want to discuss and stuck with the degraded fluid angle, and when we pushed it a bit yesterday the guy responded with ... 'ah well if you've left the bike bike sitting for a couple of days, maybe that's what's done it'  to which we responded, we leave bikes sitting for weeks if not months on end over winter periods, never had issues before.
Where we store the bikes now is a much warmer and drier place than where we used to have them, so don't have the same level of moisture/cold risk.

The bike is under currently under warranty, but from our perspective who says it won't just happen again out the blue as it did this time .... by which time warranty could be out, hence looking for thoughts on what could be underlying reason or just one of those things?

The garage attitude/responses makes us more suspicious, as they appear to be paddling for all they are worth.

 on: March 18, 2018, 12:03:47 PM 
Started by CBr6y - Last post by The Wizard of MOz
What about the slave cylinder? Seals?

 on: March 18, 2018, 10:38:11 AM 
Started by CBr6y - Last post by Alzo
Then moisture or air would have that effect.

 on: March 17, 2018, 11:03:22 PM 
Started by CBr6y - Last post by CBr6y
Clutch had no pressure whatsoever

 on: March 17, 2018, 10:53:37 PM 
Started by CBr6y - Last post by GRUMPY
When you say the clutch was gone, do you mean the clutch lever had no pressure or it had pressure but wasn't disengaging the drive ?

 on: March 17, 2018, 09:30:11 PM 
Started by CBr6y - Last post by Alzo
Moisture in the fluid....or air in the system and a quick bleeding has resolved the situation...but all said the lid of the reservoir would need to come off to do a complete bleed and they must have been real careful on removal.

Pages: [1] 2 3 ... 10

Page created in 0.086 seconds with 15 queries.